Overclockers Australia Forums
OCAU News - Wiki - QuickLinks - Pix - Sponsors  

Go Back   Overclockers Australia Forums > General Topics > Troubleshooting Help

Notices


Sign up for a free OCAU account and this ad will go away!
Search our forums with Google:
Reply
 
Thread Tools
Old 4th December 2010, 8:36 PM   #1
Tenoq Thread Starter
Member
 
Tenoq's Avatar
 
Join Date: Mar 2003
Location: Melbourne
Posts: 4,063
Default Falcon SSD performance degradation

Hi all!

I've got a first-gen Falcon 128GB in my Win 7 box, currently running the 1819 firmware (not the latest, because updating is such a PITA).

Now unfortunately for me, although this firmware supports TRIM (AFAIK) it doesn't seem to be working on my box. I AM running the new AMD AHCI driver (1.2.1.263) which supposedly supports TRIM, but my write performance has basically halved since the last time I tested it.
  • I've tried running wiper.exe - no joy. ("No drive installed proper firmware found")
  • I've tried reverting to the MS AHCI driver - no joy, and benches even lower.

So... how do I get TRIM back? How long does it take? How do you force it to run? Help!?!
__________________
Successful traders: MANY!
Tenoq is offline   Reply With Quote

Join OCAU to remove this ad!
Old 4th December 2010, 10:31 PM   #2
OldnBold
Member
 
Join Date: Oct 2004
Location: Canberra
Posts: 4,101
Default

What OS are you running?
__________________
ASUS Owners Club
OldnBold is offline   Reply With Quote
Old 4th December 2010, 10:50 PM   #3
Cpt.J.Sparrow
Member
 
Cpt.J.Sparrow's Avatar
 
Join Date: Sep 2010
Location: Glen Waverley, VIC
Posts: 484
Default

Have you installed that AHCI driver when installing Win 7?

If you did after installing Windows, it might cause some performance hits on AMD rigs. I don't know why; I am guessing AHCI driver Win 7 comes with doesn't like being replaced by AMD one.
__________________
Gadgets Galaxy Player 5.8 | G2 | iPad 4 | irDAC | Soloist | TH-900 | PowerShot SX1 IS Game Console Xbox 360 Gaming PC i7 4790K | Maximus VII Ranger | 1866MHz 32GB | M550 256GB | RE4 1TB | GeForce GTX 980 G1 Gaming | AX850 | Shadow | Windows 7 Professional 64-bit | 30" WQXGA IPS Home PC i3 2105 (HD3000) | P8H67-I Deluxe | 1333MHz 4GB | M4 64GB | DVD-Multi | M12II 620W | Colossus Mini-ITX | Winows 7 HP 32-bit | 27" Full HD TN LED NAS TurboNAS TS-119P+
Cpt.J.Sparrow is offline   Reply With Quote
Old 4th December 2010, 11:06 PM   #4
Tenoq Thread Starter
Member
 
Tenoq's Avatar
 
Join Date: Mar 2003
Location: Melbourne
Posts: 4,063
Default

Quote:
Originally Posted by OldnBold View Post
What OS are you running?
As posted in the OP.

Quote:
Originally Posted by Cpt.J.Sparrow View Post
If you did after installing Windows, it might cause some performance hits on AMD rigs. I don't know why; I am guessing AHCI driver Win 7 comes with doesn't like being replaced by AMD one.
I did install it after installing Windows - but at the time it benched about 10% faster than the standard Microsoft one so I was quite happy with that. (Although WEI scored it significantly slower, 6.8 vs 7.3 with the stock driver. But every bench actually reported it as being measurably faster).

Now the read speed is still very high, (220MB/s) but the write speed is atrocious (50-60MB/s) and my only conclusion is that TRIM isn't working. So how do I make it "do its thing", so to speak?
__________________
Successful traders: MANY!
Tenoq is offline   Reply With Quote
Old 5th December 2010, 6:37 PM   #5
terrastrife
Member
 
terrastrife's Avatar
 
Join Date: Jun 2006
Location: ADL/SA The Monopoly State
Posts: 17,175
Default

try a tony trim.

i cant gurantee this will work fo ryou, but if you could simply try as cleaner ff.exe in ff mode first.

windows trim is useless, thats the bottom line. gc works ok as long as you are logged out of your pc for a couple of hours a day.

i run a tonty trim every 3-4 weeks on my samsung ssd.
__________________
D90/70-200mm2.8/35mm1.8/SB900
Watercooled Tt Urban S31/X79-UP4/i7 3930K/64GB RipjawsZ/SLI GTX 670/Intel SSDs/38TB FlexRAID
terrastrife is offline   Reply With Quote
Old 6th December 2010, 1:13 PM   #6
Tenoq Thread Starter
Member
 
Tenoq's Avatar
 
Join Date: Mar 2003
Location: Melbourne
Posts: 4,063
Default

Quote:
Originally Posted by terrastrife View Post
try a tony trim.

i cant gurantee this will work fo ryou, but if you could simply try as cleaner ff.exe in ff mode first.

windows trim is useless, thats the bottom line. gc works ok as long as you are logged out of your pc for a couple of hours a day.

i run a tonty trim every 3-4 weeks on my samsung ssd.
Legend!

Worked perfectly. The results have me benching even higher than I was when I first got the drive!

Results:
Code:
-----------------------------------------------------------------------
CrystalDiskMark 3.0 x64 (C) 2007-2010 hiyohiyo
                           Crystal Dew World : http://crystalmark.info/
-----------------------------------------------------------------------
* MB/s = 1,000,000 byte/s [SATA/300 = 300,000,000 byte/s]

           Sequential Read :   236.813 MB/s
          Sequential Write :   144.167 MB/s
         Random Read 512KB :   207.380 MB/s
        Random Write 512KB :   188.838 MB/s
    Random Read 4KB (QD=1) :    27.134 MB/s [  6624.5 IOPS]
   Random Write 4KB (QD=1) :    17.830 MB/s [  4353.0 IOPS]
   Random Read 4KB (QD=32) :    64.246 MB/s [ 15685.1 IOPS]
  Random Write 4KB (QD=32) :    18.618 MB/s [  4545.4 IOPS]

  Test : 100 MB [C: 44.7% (53.2/119.1 GB)] (x5)
  Date : 2010/12/06 13:09:12
    OS : Windows 7 Ultimate Edition [6.1 Build 7600] (x64)
__________________
Successful traders: MANY!
Tenoq is offline   Reply With Quote
Old 7th December 2010, 3:31 PM   #7
4wardtristan
Member
 
4wardtristan's Avatar
 
Join Date: Apr 2008
Location: brisbane
Posts: 1,183
Default

can you please post a link for tony-trim? my breif googling isnt turning up much. Thanks.

edit: found it

http://www.ocztechnologyforum.com/fo...-EOL-OCZ-SSD-s.
__________________
trades - over $5k of trades and counting.

OCAU SSD CLUB #226

Last edited by 4wardtristan; 7th December 2010 at 3:39 PM.
4wardtristan is offline   Reply With Quote
Reply

Bookmarks

Sign up for a free OCAU account and this ad will go away!

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 10:08 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd. -
OCAU is not responsible for the content of individual messages posted by others.
Other content copyright Overclockers Australia.
OCAU is hosted by Internode!