Overclockers Australia Forums
OCAU News - Wiki - QuickLinks - Pix - Sponsors  

Go Back   Overclockers Australia Forums > Software Topics > PC Games

Notices


Sign up for a free OCAU account and this ad will go away!
Search our forums with Google:
Reply
 
Thread Tools
Old 17th March 2005, 2:23 AM   #1
aspring Thread Starter
Member
 
aspring's Avatar
 
Join Date: Jun 2001
Location: Perth
Posts: 156
Default System Shock 2 --- problem...

Hey there all! I've recently purchased SYSshock2 and have run into a problem running it...

I'm using win2k and sucessfully installed syshock using "e:\setup –lgntforce"

I've patched it to version 2.3

It ran fine at this point; but with no cut scenes... so I executed "regsvr32 d:\games\sshock2\LGVID.AX" thus registering the Video codecs - thus video now plays... however, when running the game I now get "D3d device driver does not accurately report the correct amount texture memory usage..." whenever I get to the actual game.

I have re-installed the game
- no joy

I have copyed the w2k friendly exe (http://www.brave.net.nz/shock2_xp_2000_fix.zip) over the original...
- no joy

I've executed "regsvr32 /u d:\games\sshock2\LGVID.AX" to unregister the codec's and, yes, no joy.

Any idea's anyone? It's frustrating to have been able to run the game then have it crap out when the rest of it works.

...although the intro cutscene is pretty good

Cheers!
aspring is offline   Reply With Quote

Join OCAU to remove this ad!
Old 17th March 2005, 3:20 AM   #2
Mug
Member
 
Mug's Avatar
 
Join Date: Dec 2004
Location: Vic
Posts: 92
Default

Great, something I know how to deal with

First of all, to fix that directx problem, open the file cam.cfg from the Shock2 install directory using Notepad and add the line
safe_texture_manager
to the bottom of it.

Also, if you have hyperthreading or duel CPUs, be sure to download my system shock 2 multithread patch. You'll have to use that windows xp friendly exe you've got there before applying the patch. (that exe isnt windows XP friendly, it just unwraps the EXE so it doesnt use EA's evil safedisk which is the most incompatible piece of crap ever.), anyway, you can find my System Shock 2 XP Guide and a link to my multithread patch at this URL: http://www.ttlg.com/forums/showthread.php?t=69958
__________________
Main System: [ Octo-Core PPC 3.2GHz | 256MB XDR 3.2GHz RAM | nVidia G70 256MB GDDR3 + 128MB Shared XDR | 2xBDROM | 32" 1920x1080 Samsung LCD | 60GB SATA ]
Secondary System: [ Tri-Core PPC 3.2GHz | ATi Dual-Xenos R600 10MB eDRAM | 512MB GDDR3 Shared | 12xDVDROM | 32" 1920x1080 Samsung LCD | 20GB Pty. Interface HDD ]
Mug is offline   Reply With Quote
Old 17th March 2005, 9:55 AM   #3
aspring Thread Starter
Member
 
aspring's Avatar
 
Join Date: Jun 2001
Location: Perth
Posts: 156
Default

cheers! I'm up and running... away from screaming monkeys!

Thanks!
aspring is offline   Reply With Quote
Reply

Bookmarks

Sign up for a free OCAU account and this ad will go away!

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 5:10 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd. -
OCAU is not responsible for the content of individual messages posted by others.
Other content copyright Overclockers Australia.
OCAU is hosted by Internode!