Overclockers Australia Forums
OCAU News - Wiki - QuickLinks - Pix - Sponsors  

Go Back   Overclockers Australia Forums > Software Topics > Windows Operating Systems

Notices


Sign up for a free OCAU account and this ad will go away!
Search our forums with Google:
Reply
 
Thread Tools
Old 13th March 2008, 9:57 PM   #1
ReP0 Thread Starter
Awaiting Email Confirmation
 
Join Date: Sep 2002
Location: Sydney
Posts: 4,237
Default Stopping Vista going into sleep while downloading...

Anyone have any ideas how to stop Vista going into sleep mode while Opera is downloading something? Seems my assumption about Opera taking care of it automatically didn't work out.

[Edit: hmm maybe the transfer timed out, might not be Opera's fault..Anyway if there is a trick setting to it let me know]

Last edited by ReP0; 13th March 2008 at 10:30 PM.
ReP0 is offline   Reply With Quote

Join OCAU to remove this ad!
Old 14th March 2008, 12:35 AM   #2
Idryss
Member
 
Idryss's Avatar
 
Join Date: Jul 2005
Location: Central Coast
Posts: 2,048
Default

Put media player onto play and mute it. Its what I do
__________________
Steam: Idryss
Idryss is offline   Reply With Quote
Old 14th March 2008, 12:39 AM   #3
Rezin
Member
 
Rezin's Avatar
 
Join Date: Oct 2002
Posts: 8,392
Default

Can't you specify x hours/minutes to 'put the computer to sleep' in Control Panel > Power Options > Edit Plan Settings, or were you looking for a way to automatically do it whenever Opera was running?
Rezin is offline   Reply With Quote
Old 14th March 2008, 12:52 AM   #4
Idryss
Member
 
Idryss's Avatar
 
Join Date: Jul 2005
Location: Central Coast
Posts: 2,048
Default

You could, but you'd have to change it every time. I think that vista thinks that any web browser, including their DL manager, isnt downloading even if it is (might think its just refreshing stuff automaticaly or something), but I have found vista wont goot sleep with uTorrent or similar. havent tried getright tho.
__________________
Steam: Idryss
Idryss is offline   Reply With Quote
Old 14th March 2008, 2:09 AM   #5
Rezin
Member
 
Rezin's Avatar
 
Join Date: Oct 2002
Posts: 8,392
Default

According to this page...

Quote:
PCs may not enter sleep mode when they have a file open over the network. Graphics-intensive screen savers can prevent PCs from entering sleep mode as well, and should be disabled.

Otherwise Vista should not allow software applications to stop it from going to sleep. However, it is possible for a network administrator to change this default, allowing applications to "veto" sleep when they are busy. The default can be changed using Group Policy, but cannot be set through the Power Options applet in the Control Panel.
gpedit.msc > Computer Configuration > Administrative Templates > System > Power Management > Sleep Settings > Turn on Applications to Prevent Sleep Transitions (Plugged In).

Does that help?
Rezin is offline   Reply With Quote
Old 14th March 2008, 10:33 PM   #6
Idryss
Member
 
Idryss's Avatar
 
Join Date: Jul 2005
Location: Central Coast
Posts: 2,048
Default

Nice find. Will try and see if that helps tomorrow night.
__________________
Steam: Idryss
Idryss is offline   Reply With Quote
Old 15th March 2008, 3:01 PM   #7
tin
Member
 
tin's Avatar
 
Join Date: Jul 2001
Location: Narrabri NSW
Posts: 5,744
Default

Quote:
Originally Posted by Idryss View Post
Put media player onto play and mute it. Its what I do
I'd have said that normally too... But I discovered last night while watching a movie that WMP wasn't preventing the screensaver (I'm using the supplied "Bubbles" screensaver) coming on. Setting was set correctly, and I even tried flipping it over and back. Still didn't prevent the screensaver.

I have a feeling it's due to multiple monitors doing something weird. WMP has never worked right with more than one monitor (like full screen draws a part of the border on the adjacent screen).

Now, of course it may still prevent sleep mode, but I'd be doing some testing now after I found that.
__________________

The software required Win95 or better, so I installed Linux.
Question marks are the new full stop?
tin is offline   Reply With Quote
Old 15th March 2008, 3:22 PM   #8
Elyzion
Member
 
Elyzion's Avatar
 
Join Date: Oct 2004
Location: Singapore
Posts: 6,376
Default

My vista stays on till the file has finished downloading, then since theres no network activity it shuts down.
__________________
Quote:
Originally Posted by SyN View Post
next time you see a dog, go up close to it and say loudly with furious anger 'ENGLISH MOTHERFUCKER, DO YOU SPEAK IT'
Elyzion is offline   Reply With Quote
Old 15th March 2008, 3:30 PM   #9
tin
Member
 
tin's Avatar
 
Join Date: Jul 2001
Location: Narrabri NSW
Posts: 5,744
Default

Quote:
Originally Posted by Elyzion View Post
My vista stays on till the file has finished downloading, then since theres no network activity it shuts down.
Probably depends on the program in use. What are you using that prevents it?
__________________

The software required Win95 or better, so I installed Linux.
Question marks are the new full stop?
tin is offline   Reply With Quote
Old 15th March 2008, 3:51 PM   #10
Elyzion
Member
 
Elyzion's Avatar
 
Join Date: Oct 2004
Location: Singapore
Posts: 6,376
Default

Quote:
Originally Posted by tin View Post
Probably depends on the program in use. What are you using that prevents it?
uTorrent. I donno what settings i changed but basically i just set my torrent to not seed so when its downloaded my pc sleeps.
__________________
Quote:
Originally Posted by SyN View Post
next time you see a dog, go up close to it and say loudly with furious anger 'ENGLISH MOTHERFUCKER, DO YOU SPEAK IT'
Elyzion is offline   Reply With Quote
Old 15th March 2008, 5:15 PM   #11
ReP0 Thread Starter
Awaiting Email Confirmation
 
Join Date: Sep 2002
Location: Sydney
Posts: 4,237
Default

Quote:
Originally Posted by Elyzion View Post
uTorrent. I donno what settings i changed but basically i just set my torrent to not seed so when its downloaded my pc sleeps.
Or you could just go to the options->autoshutdown menu and choose your action once downloads complete in utorrent rather than relying on the OS to timeout.


To everyone:
Thanks for all the suggestions. The media player one seems simplest as I always have an mp3 around which I can put into loop.

Like I said perhaps the download had an error in the first place and closed down followed by a sleep due to inactivity. Hard to tell which came first without being infront of the screen. Perhaps I don't need any of these. My sleep timeout is 15 minutes so next time I download a large file off the web I'll hang around and see what happens.

Last edited by ReP0; 15th March 2008 at 5:19 PM.
ReP0 is offline   Reply With Quote
Old 23rd March 2008, 8:52 PM   #12
Elyzion
Member
 
Elyzion's Avatar
 
Join Date: Oct 2004
Location: Singapore
Posts: 6,376
Default

Quote:
Originally Posted by tin View Post
What are you using that prevents it?
Ahhh, i found it.

Was turning off a setting and noticed.

Preferences > Downloads > Other Settings

"Prevent Standby if there are active torrents"

__________________
Quote:
Originally Posted by SyN View Post
next time you see a dog, go up close to it and say loudly with furious anger 'ENGLISH MOTHERFUCKER, DO YOU SPEAK IT'
Elyzion is offline   Reply With Quote
Reply

Bookmarks

Sign up for a free OCAU account and this ad will go away!

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +10. The time now is 1:50 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd. -
OCAU is not responsible for the content of individual messages posted by others.
Other content copyright Overclockers Australia.
OCAU is hosted by Internode!