I think I have my HDD led I/O connector backwards, can that damage the system at all?

Discussion in 'Newbie Lounge' started by RagingKoala, Jul 17, 2017.

  1. RagingKoala

    RagingKoala Member

    Joined:
    Sep 11, 2016
    Messages:
    29
    So I just got finished putting together the new build and everything works, USB, headphone etc (which is a miracle considering I've never had to do those front pin connectors before).

    The system ON led works fine, but I've noticed there is no flashing hdd light (Fractal R5)

    I suspect maybe the + and - are backwards on the motherboard. I may at some point go back and fix that but its hard to get to when the system is fully together.

    Will that damage anything to just let it run sans HDD flashing light if the terminals are backwards? Or not at all?
     
  2. havabeer

    havabeer Member

    Joined:
    Dec 12, 2010
    Messages:
    2,850
    the short answer is "no, it will not affect anything"
     
  3. RagingKoala

    RagingKoala Member

    Joined:
    Sep 11, 2016
    Messages:
    29
    Awesome, thanks a lot. The OCD perfectionist in me had to pull apart the front connectors and do it the right way, it seems 'label up' on the Fractal connectors is incorrect for some of the inputs.
     
  4. cbjaust

    cbjaust Member

    Joined:
    Sep 11, 2003
    Messages:
    967
    Location:
    Melbourne
    Well if you're truly OCD about it you'll grab a 1mm jeweler's screw drive and slip the plastic molex off the contacts and put then back to match the labels. :D
     

Share This Page