Atari SC1435 Monitor Troubleshooting and Repair

Discussion in 'Retro & Arcade' started by aXLe, Jan 31, 2017.

  1. OP
    OP
    aXLe

    aXLe Member

    Joined:
    Jun 27, 2001
    Messages:
    1,131
    Location:
    Brisbane
    The vertical IC(s) arrived today!

    [​IMG]

    Bargain at 50p a pop so I couldn't resist getting 10 of them - never know when you might need one :)

    I fitted one into the board and soldered it in place, then the moment of truth - do I have vertical deflection??

    YES!

    [​IMG]

    Hard to tell from the photo I know, but with the brightness cranked up the screen is now being painted by the electron beam. Quite a bit of burn in is noticeable on this screen (must have been used for one specific application for some time I suspect). Still, it's not too bad when you have something running on it - fades into the background.

    So the ultimate test was to drag out my Apple 2gs and plug it in using the RGB cable that I made when fixing the 1084S monitor previously.

    Woohoo!

    [​IMG]

    Looks good :)

    I've also pretty much finished the PCB layout for my version of Bob Parkers LOPT/FBT Tester which I've designed to fit in a UM5 jiffy box. Front PCB artwork which gives full credit to the original designer (my makers marks is on the the back):

    [​IMG]

    I've actually added the sensitivity selection function but otherwise the design is much the same (other than being surface mount).

    Still deciding whether to use a blue soldermask or black. Components are mounted on the rear of the board, including OSRAM reverse mount LED's which shine back up through the holes on the PCB.

    Anyways, there is not much left to do on this monitor - I still need to take a quick look at the degauss and fit a replacement diode for the one that I bypassed (I'll fit a higher voltage part to prevent the monitor going into HV shutdown).

    I'll probably let it run a few hours at the weekend to be sure its all good and then it goes back to Mikro (who has been very patient!) for his Atari STe :)
     
    Last edited: Dec 15, 2017
  2. badmofo

    badmofo Member

    Joined:
    Oct 10, 2011
    Messages:
    611
    Location:
    Australia
    Amazing work on this yet again - it must be a thrill to see them come back to life. Love a good CRT.
     
  3. mikro

    mikro Member

    Joined:
    Jan 24, 2017
    Messages:
    2
    Location:
    Brisbane
    Fantastic job, Mikro's been stalking this thread every day. :)

    So the culprit was the flyback and the vertical IC?

    Btw great to hear about your progress on the ring tester, after seeing all this I'm sure I want one, I hope it will be available for purchase soon.

    Once again, hats off mate, one hell of a job.
     
  4. OP
    OP
    aXLe

    aXLe Member

    Joined:
    Jun 27, 2001
    Messages:
    1,131
    Location:
    Brisbane
    Thanks guys - I did enjoy working on this one and learnt a lot from it :) It does give a warm fuzzy feeling when you finally get it running.

    Yes - the culprits were the flyback and vertical IC - I replaced the horizontal output transistor and snubber cap plus a couple of filter caps on the B+ line just for good measure as they do get a hard time, but the original parts were still ok.

    I will have a few ring tester boards available - I haven't used the OSRAM PointLED's before so I just want to check the currents at required brightness before I commit the design and have the boards made :)

    
     
    Last edited: Feb 28, 2017
  5. mikk

    mikk Member

    Joined:
    Oct 9, 2006
    Messages:
    50
    Location:
    Brisbane
    Great to see this thing running!

    I used to have one. Mine also had a rotating stand that clicked into the bottom. I recognise that board.

    Opened the monitor up to do some very fine adjustments. It produced quite a good picture once it was all set up properly. Sharpness and geometry were pretty good compared to many of the cheapies I saw being used on a lot of PCs at the time.

    Mine copped a lot of abuse and kept going. Ran it at fairly low brightness so never had a problem with burn in. Also a lot of gaming meant that the picture changed quite often anyway.

    Thanks for the detail in this thread. Electronics repair certainly is a dying art, especially when it comes to CRT monitors.
     
  6. TRG.dOinK

    TRG.dOinK Member

    Joined:
    Jun 27, 2002
    Messages:
    4,397
    Location:
    Melb East
    Great thread, really interesting and informative.

    Bit O/T - but looks like you're using a JBC soldering iron kit, am I right? :D

    How do you find it?

    We use C245 handles (well when I worked ther) with cartridges C245030, C245731, C245906 though tip 030 was used to melt plastic around a CCD, found the unit pretty good tbh, heated up the tips pretty quickly to 300 and 350 degrees :)

    Kind of miss my old job with all the gadgets, torque drivers, spare parts, tools etc etc etc...
     
    Last edited: Mar 27, 2017
  7. OP
    OP
    aXLe

    aXLe Member

    Joined:
    Jun 27, 2001
    Messages:
    1,131
    Location:
    Brisbane
    Yeah I use JBC - I have compact station with the T245 handpiece, plus I also have a micro-tweezer station.

    Ideally I'd like to trade up to a four tool station, but by the time you buy all the tool stands etc its rather pricey!

    I like the fast heat-up, thermal capacity, short hand to tip distance, the fast cartridge changes.

    I think the menu system could be a bit better, but it's handy to have a few temps that you can quickly switch between.

    Before the JBC I had a Hakko 936 which I still have, but it's tucked away for emergency use only. Very hard to go back to a 936 when you've just a JBC :)

    I wouldn't mind getting a T210 handpiece and a couple of small cartridges for the really tiny stuff - my compact station would accept that handpiece as well.
     
  8. TRG.dOinK

    TRG.dOinK Member

    Joined:
    Jun 27, 2002
    Messages:
    4,397
    Location:
    Melb East
    Good feedback. Your right, they were rather pricey but I liked the units.

    I believe the idea for us also changing over was so that we could 'log' the temps used when soldering, as we needed to write down two different temperatures for two different tasks (as we used different types of solder), but in the end we still ended up writing that down manually on a form.

    Your right in regards to going back to the older units. Before that, we used Weller from memory (WSD81? I can't remember), but its in my garage now too since they wanted to get rid of them. Nothing wrong with them either I guess, but not sure I'd go back to one handle piece when the JBC allows you to have two hooked up :)

    Did you ever look at the new type of Weller units to compare? At the time of choosing, we did get one of the new Weller units (think it was a WX2). Personally I never got to use it, but I think it was the preferred unit by our Tech Liason but because it was so new, Weller couldn't deliver the units in time and were having supply issues if I recall correctly.

    Oh the memories and playing with tech...
     
    Last edited: Mar 27, 2017
  9. schmoove

    schmoove Member

    Joined:
    Oct 13, 2006
    Messages:
    716
    Location:
    Asia
    Just wanted to add, epic thread! Love your work Axle.
    Very interesting and informative.
     
  10. money_killer

    money_killer Member

    Joined:
    Apr 10, 2010
    Messages:
    2,056
    Location:
    Sunshine Coast
    Awesome thread nice work
     
  11. OP
    OP
    aXLe

    aXLe Member

    Joined:
    Jun 27, 2001
    Messages:
    1,131
    Location:
    Brisbane
    I'm finally getting around to migrating my images from Photobucket to Google Drive - this thread now fixed :)
     

Share This Page