Bios display

Discussion in 'Overclocking & Hardware' started by Mr B, May 26, 2019.

  1. Mr B

    Mr B Member

    Joined:
    Oct 27, 2015
    Messages:
    31
    Hey all

    Have a ROG Strix B350-F mobo and Ryzen 1700X and looking to update the bios.

    Having trouble actually entering bios - restart, keep pressing delete and there is no display at all - just black screen. I think it might be getting in there, as the lights on the GPU etc stay on and if I do ctr/alt/del it reboots and goes into windows normally.

    I dont see the splash screen at all when booting - straight to windows screen.

    Any ideas whats going on? How do I get into bios?

    Edit: Using Display port connector for monitor
     
    Last edited: May 26, 2019
  2. Bold Eagle

    Bold Eagle Member

    Joined:
    Jun 28, 2008
    Messages:
    8,833
    Location:
    Brisbane
    Mr B likes this.
  3. OP
    OP
    Mr B

    Mr B Member

    Joined:
    Oct 27, 2015
    Messages:
    31
    Thanks Bold Eagle, hadn't thought of that.

    Spot on - dual monitor setup, both from the GPU, only use the second one for work and don't have it on when playing around.

    Bios appears on that, through the HDMI, even though that is the secondary display.
     
  4. Bold Eagle

    Bold Eagle Member

    Joined:
    Jun 28, 2008
    Messages:
    8,833
    Location:
    Brisbane
    It can be a bit of a nuisance the alternative would be to use a dongle (DP to HDMI or DVI) I don't know why it is like this but the most pragmatic is to note BIOS will render at HDMI for it's highest.
     
  5. OP
    OP
    Mr B

    Mr B Member

    Joined:
    Oct 27, 2015
    Messages:
    31
    Just an idiosyncrasy to keep in mind perhaps.

    Bios updated, happy me.

    Thanks again.
     
  6. Bold Eagle

    Bold Eagle Member

    Joined:
    Jun 28, 2008
    Messages:
    8,833
    Location:
    Brisbane
    NPS - please go and edit the OP (first post) and change the tag to 'Solved'.
     

Share This Page

Advertisement: