Catalyst 5.2

Discussion in 'Video Cards & Monitors' started by Fodder, Feb 10, 2005.

  1. Fodder

    Fodder (Banned or Deleted)

    Joined:
    Dec 23, 2001
    Messages:
    10,638
    Location:
    Sunny Melbourne
    New drivers are out. Looks like some more tweaks to the CCC (finally they let us change settings without loading the POS up) but as usual more than a few quirks as well. There's also a new beta driver for XP64.
     
    Last edited: Feb 10, 2005
  2. Armunn

    Armunn Member

    Joined:
    Jun 28, 2001
    Messages:
    3,407
    Location:
    Melbourne, VIC
    I hope these improvements are reflected across the board in games and not just those specific applications.
     
  3. Fish_Munger

    Fish_Munger Member

    Joined:
    Nov 8, 2002
    Messages:
    666
    Location:
    Sydney
    sic new cats! :tongue:.5.1 cats are crap lets hope these work better in HL2 like kick ass 4.12 whos ya mac daddy driver
     
  4. Optinreich

    Optinreich Member

    Joined:
    Dec 18, 2004
    Messages:
    533
    Location:
    Pub
    No real gain here using the 5.2's awww well.
     
  5. Wacko02

    Wacko02 Member

    Joined:
    May 26, 2003
    Messages:
    872
    Location:
    Melbourne
    aarrrgghh..... buggy as all hell.
    The control centre itself keeps suffering a fatal error and closes. And I'm getting error messages everytime i try to change a setting when playing around with extended desktop to a TV.

    Will try a few games now and see how I go, but i'm not holding my breath.
     
  6. Wylf

    Wylf Member

    Joined:
    Jul 22, 2002
    Messages:
    972
    Location:
    Canberra
    did you fully uninstall the previous control centre? I had this problem until I uninstalled absolutely everything ATI-related. My subsequent cat. install worked a treat.

    No real perf increases though (9600xt)
     
  7. MR CHILLED

    MR CHILLED D'oh!

    Joined:
    Jan 2, 2002
    Messages:
    136,487
    Location:
    Omicron Persei 8
    They seem a bit early this month...

    That doesn't surprise me....even though it has worked ok for me I've hated since it came out. Firstly it lagged my system ever so slightly, and secondly for the life of me I just could not find out how to get TV Out working so that both monitor and TV could be played at the same time. I've ditched it long ago for the normal cats :thumbup:
     
  8. Vaempyr

    Vaempyr Member

    Joined:
    Jan 15, 2002
    Messages:
    4,242
    Location:
    melbourne.au
    I have a 9600XT, and given that I'm using the Catalyst 4.2s, my drivers are now a year old.

    So, is it worth upgrading?

    (I maninly play Morrowind and NBA Live 2004).
     
  9. Akimbo

    Akimbo Member

    Joined:
    Dec 2, 2003
    Messages:
    1,673
    Location:
    Perth W.A.
    im getting a weird CLI.EXE error in this revision, had 5.1's installed, and just did a direct update.

    must have to delete the oldys.
     
  10. Azsen

    Azsen Member

    Joined:
    Oct 15, 2004
    Messages:
    1,174
    Location:
    Sydney
    First time I uninstalled, then installed the new drivers. CS Source was running like an absolute dog. Choppy as hell and really laggy even on my XT PE which I hadn't changed any in game settings.

    So anyway went through a good cleanout of all the the drivers, registry, services, unused devices and did a few tweaks as described here (Catalyst 5.2 Tweak guide).

    And then there was some good improvement in CS Source after all that, very smooth. Then it changed map to CS_Havana and it started getting choppy again. :( Like it would go for 20secs smoothly, then start getting quite choppy. Framerates were still high, 50-75fps (vsync @ 75hz).

    I thought it might be lag, but I tried it by making my own server and that did it on there too.

    Anyone got any ideas?
     
    Last edited: Feb 11, 2005
  11. Akimbo

    Akimbo Member

    Joined:
    Dec 2, 2003
    Messages:
    1,673
    Location:
    Perth W.A.
    Gotta uninstall everything ATi related before installing 5.2's, even delete everything INSIDE the C:\Program Files\ATi Technologies\ folder.
     
  12. Wacko02

    Wacko02 Member

    Joined:
    May 26, 2003
    Messages:
    872
    Location:
    Melbourne
    OK, update on my previous whinge. I uninstalled "some" of the ATI stuff and reinstalled Cat 5.2 and everything is better. I'm running a 9700Pro AIW and was lazy the first time and just installed over the previous cats. (Note to self.... don't do this :rolleyes: ). I ended up only uninstalling the ATI Control Center, and the ATI Display Driver, as I hate reinstalling the MMC and ATI Remote wonder software. Also installed the .Net 1.1 stuff from micro$oft too.

    Anyway, this seems to be working better now and haven't had any problems so far. I haven't played with the extended TV output yet, but this was working before anyway. Games seem to be fine, although I can't notice any diffference from 4.6 which i was using previously.
     
  13. MR CHILLED

    MR CHILLED D'oh!

    Joined:
    Jan 2, 2002
    Messages:
    136,487
    Location:
    Omicron Persei 8
    Last edited: Feb 12, 2005
  14. Wacko02

    Wacko02 Member

    Joined:
    May 26, 2003
    Messages:
    872
    Location:
    Melbourne
    Yeah, i'm about to roll them back to something more stable. I am getting an error message everytime I get to my desktop when i start up, with "the Control Panel has to shut down". It still shows in my icon tray as running, but my extra mouse buttons (back & forwards on the mx500) are disabled :confused:

    Anyway, going back to 4.6.
     
  15. Forgiven

    Forgiven Member

    Joined:
    Jan 4, 2004
    Messages:
    929
    Location:
    Brizzie
    Go for 4.12 it is by far a very good catalyst..
     
  16. Fish_Munger

    Fish_Munger Member

    Joined:
    Nov 8, 2002
    Messages:
    666
    Location:
    Sydney
    yep Ati cat 4.12Beta gives me best framerate and IQ!.Ati Cat 5.2 is a good driver still so I recommend it for any ATi card.That ccc software is a god dam joke,some retards with too much spare time made that :upset:
     
    Last edited: Feb 14, 2005
  17. Oblong Cheese

    Oblong Cheese Member

    Joined:
    Aug 31, 2001
    Messages:
    10,581
    Location:
    Brisbane
    I don't mean to troll, but since swapping to an nVidia-powered system I can't say that I miss the weekly driver updates from ATi. :p
     
    Last edited: Feb 14, 2005
  18. MR CHILLED

    MR CHILLED D'oh!

    Joined:
    Jan 2, 2002
    Messages:
    136,487
    Location:
    Omicron Persei 8
    Monthly :)

    I prefer regular updates.
     
  19. Geforcer

    Geforcer New Member

    Joined:
    Jun 26, 2001
    Messages:
    64
    I upgraded from the 5.1's, and had problems on 2 systems I tried them on. First system would lockup in Tiger Woods 2005 (only tried this game). The 2nd system would crash out of 3d Mark 05 towards the end of the bench. Happened 3 times. Removed them and put back 5.1's and everythings fine now. So far no crashes yet.
     
  20. FearTec

    FearTec Member

    Joined:
    Jul 22, 2003
    Messages:
    2,389
    Location:
    NSW
    I am using 1 year old drivers on my rig (below) with no problems in any games (doom3, farcry, nfsu2, call of duty, blitzkrieg, the sims2, sim city 3, etc etc etc etc).

    The new catalyst were unreliable for me.
     

Share This Page