Catalyst 8.9 released

Discussion in 'Video Cards & Monitors' started by TaroT, Sep 18, 2008.

  1. TaroT

    TaroT Member

    Joined:
    Jan 18, 2002
    Messages:
    8,705
    Location:
    Hazelbrook nsw 2779
    drivers


    http://game.amd.com/us-en/drivers_catalyst.aspx


    release notes


    http://game.amd.com/us-en/content/pdf/catalyst8_9.pdf

    Have fun


    Initial results

    Q6600@3Ghz
    4 gig patriot 1066@1066 5 5 5 15
    Vista business sp1 64 bit
    4870 1GB HIS 785/925
    Ugly betty settings is all app controlled or off
    pretty settings is all maxed out including adaptive AA and 4x4 box AA



    3DVantagetoss

    http://service.futuremark.com/compare?3dmv=384771
    9431
    up about 170 points on 8.8 same settings.

    3Dtoss06
    http://service.futuremark.com/compare?3dm06=8210566

    15138

    down around 300 points from my 8.8 run of 15483

    UT3

    patched to 1.3 as it SHOULD be :)

    65.6 fps in ugly betty mode (around the same but felt good...nice and smooth)

    60.1fps in pretty mode (all cats turned up including 4x4 box AA)

    never missed a beat and looks absolutely stunning (up around 4 maybe 5 fps on the 8.8's)



    All the above results excpet for the pretty ut3 run were done in ugly mode...no AA minimal AF etc etc

    HL2 lost coast and Counterstrike source(all done with pretty settings 4x4 box aa etc)

    125.6 for lost coast, up a few from 8.8 and in my opinion looked better
    thats with the ingame maxed out as well

    254.84 for counterstrike source again maxed out the settings
    Also up a few maybe 20 fps from the 8.8,s

    DVD video and hd dvd playback


    using powerdvd hardware acceleration and avivo settings work nicely(8.8 and before were sketchy)
    i used harry potter and the order of the pheonix hd dvd and quakity was very good and looked brilliant(bit of a change from older releases but really nothing overly noteworthy)

    avi's etc all play fine same deal with avivo working.

    All in all i give this release a thumbs up.
     
    Last edited: Sep 18, 2008
  2. eva2000

    eva2000 DDR1/DDR2/DDR3 Addict

    Joined:
    Jun 27, 2001
    Messages:
    21,902
    Location:
    Brisbane, Australia
    awesome just in time for some more ATI action :D
     
  3. dead_man

    dead_man Member

    Joined:
    Feb 2, 2005
    Messages:
    1,675
    Location:
    melbourne
    why oh why did they need to break that part
     
  4. DiGiTaL MoNkEY

    DiGiTaL MoNkEY Inverted Monkey

    Joined:
    Jun 28, 2005
    Messages:
    26,896
    Location:
    Melbourne, Victoria
    A nice an early release, thanks for the heads up TaroT.
     
  5. Shinanigans

    Shinanigans Member

    Joined:
    Apr 7, 2006
    Messages:
    4,833
    Location:
    Central Coast
    First person to post comparisons wins a cookie!
     
  6. prezident doom

    prezident doom Member

    Joined:
    Nov 24, 2004
    Messages:
    5,237
    Location:
    Brisbane
    Ill see how STALKER: Clear Sky runs on these tonight...
     
  7. shawns_maggot

    shawns_maggot Member

    Joined:
    Mar 28, 2007
    Messages:
    363
    Location:
    Mudgee - 2850
    Doh! released just as i sell one of my cards >.<
     
  8. OP
    OP
    TaroT

    TaroT Member

    Joined:
    Jan 18, 2002
    Messages:
    8,705
    Location:
    Hazelbrook nsw 2779
    well duh wheres my cookie :)

    UT3 next
     
  9. QuinYip

    QuinYip Member

    Joined:
    Jun 26, 2007
    Messages:
    113
    Location:
    Melbourne
    Google Sketch-up works with hardware acceleration now! :D
     
  10. Shinanigans

    Shinanigans Member

    Joined:
    Apr 7, 2006
    Messages:
    4,833
    Location:
    Central Coast
    [​IMG]

    You need to get it off this guy! :lol:
     
  11. DiGiTaL MoNkEY

    DiGiTaL MoNkEY Inverted Monkey

    Joined:
    Jun 28, 2005
    Messages:
    26,896
    Location:
    Melbourne, Victoria
    What type of cookie? :D
     
  12. Frontl1ne

    Frontl1ne Member

    Joined:
    Mar 10, 2008
    Messages:
    3,886
    XP 32Bit users might wanna go through here to get their drivers instead:

    http://ati.amd.com/support/driver.html

    Either I downloaded the wrong driver or something went wrong, but I wasn't able to install 8.9 going through OP's link. Anyway, the one I linked above works :)
     
  13. rakesh1983

    rakesh1983 Member

    Joined:
    Jun 24, 2006
    Messages:
    278
    Location:
    Melbourne
    Err Tarot you may want to chance the hideous yellow font in your initial post. :)

    Good to hear that there are performance updates !
     
  14. DiGiTaL MoNkEY

    DiGiTaL MoNkEY Inverted Monkey

    Joined:
    Jun 28, 2005
    Messages:
    26,896
    Location:
    Melbourne, Victoria
    In the sabretooth theme it looks okay :D
     
  15. rakesh1983

    rakesh1983 Member

    Joined:
    Jun 24, 2006
    Messages:
    278
    Location:
    Melbourne
    Lol, I'm going to assume that most users arn't on that ugly colour scheme :p
     
    Last edited: Sep 18, 2008
  16. Howiefied

    Howiefied Member

    Joined:
    Jun 3, 2002
    Messages:
    2,486
    Location:
    Adelaide
    Shit yeah! About bloody time.

    Say anyone know if they got Grid/Dirt working with this release?
     
  17. OP
    OP
    TaroT

    TaroT Member

    Joined:
    Jan 18, 2002
    Messages:
    8,705
    Location:
    Hazelbrook nsw 2779
    link seems fine to me i downloaded them from the big list.

    going through your link using the boxes ended me up at the same place...might nothave updated or you didn't refresh the page from last time...meh
    changed the colour so girlies don't cwy :p

    as for grid give it to me and i,ll be happy to test it:D
     
  18. DiGiTaL MoNkEY

    DiGiTaL MoNkEY Inverted Monkey

    Joined:
    Jun 28, 2005
    Messages:
    26,896
    Location:
    Melbourne, Victoria
  19. JamalH

    JamalH Member

    Joined:
    Aug 1, 2008
    Messages:
    1,205
    Hopefully they can fix this WoW issue im having..
     
  20. Samuka

    Samuka Member

    Joined:
    Jul 9, 2004
    Messages:
    367
    Location:
    Melbourne
    Looking forward to trying this tonight. Hopefully it will fix the BSOD crash on startup with atikmdag.sys error .

    This is on a new system with fresh install with a 4870.

    But I have my doubts..
     

Share This Page