Dell G7 with new upgrades slow and freezing

Discussion in 'Troubleshooting Help' started by Chr, Apr 15, 2019 at 9:29 AM.

Tags:
  1. Chr

    Chr New Member

    Joined:
    Sunday
    Messages:
    2
    Hi all,

    I recently purchased a brand new Dell G7 laptop. Randomly when I'm using it the mouse will freeze up for about 3-4 seconds. It's always random when this happens and can happen at any time. Could be opening a file, clicking a website link, about to open a program, etc.

    Recently this has been happening more frequently, and as of late I had a blue screen which stated the error message "DRIVER_POWER_STATE_FAILURE".

    The speed of the laptop also feels a bit slow. Considering the specs of the machine and upgrades I've done, I'm at a loss as to what's happening.

    Below are my specs:

    Model: Dell G7 7590
    CPU: 8th Generation Intel Core i7-8750H
    OS: Windows 10 Pro 64 Bit
    Ram: 1x 16GB Kingston KVR26S19D8/16 16GB 2666MHz DDR4 (Previously 1x8GB, DDR4, 2666MHz)
    Video Card: NVIDIA GeForce RTX 2060 6GB GDDR6
    Drives: Samsung 970 EVO Plus Series 1TB M.2 + Samsung MZ-76E4T0BW 860 EVO 4TB 2.5 (Previously 128GB M.2 PCIe NVMe Solid State Drive (Boot) + 1TB 5400 rpm 2.5" SATA Hard Drive)
     
  2. philquad

    philquad Member

    Joined:
    Jan 22, 2004
    Messages:
    886
    Location:
    nelson bay
    maybe try changing the power settings
    i mean its telling you the problem
    changing might just help it
    like, i have mine on
    turn off display = never
    sleep after = 10 minutes
     
    Chr likes this.
  3. FOTW

    FOTW Member

    Joined:
    Jul 20, 2002
    Messages:
    890
    Location:
    Kilcock, Ireland
    That is usually caused by GPU driver try uninstalling Nvidia graphics driver and re-install latest version. Check event viewer and see if there is any services that load before each crash.

    From Toms hardware forums try these:

    1. Navigate to Control Panel, Hardware and Sound and Power Options.
    2. Select ‘Change power settings’ next to the active power plan.
    3. Select ‘Change advanced power settings’ text link.
    4. Select ‘Change settings that are currently unavailable’.
    5. Find Graphics Settings or PCI Express and Link State Power Management and set to Maximum performance, depending on what computer you have.
    6. Find Wireless Adapter Settings and set to Maximum performance.
    7. Reboot your computer and retest.


    Sometimes it could also be the SSD or CPU driver ensure you have latest driver for SSD installed and intel management engine.
     
    Chr likes this.
  4. OP
    OP
    Chr

    Chr New Member

    Joined:
    Sunday
    Messages:
    2
    Did that last night, so far so good. It seems that the Nvidia driver from the Dell site is the issue. Downloaded the GPU driver direct from Nvidia and it's running smoothly.

    I'll hold off on marking this as solved for a few days just in case, however I think it'll be right now. Thank you everyone for your help.
     
    FOTW likes this.

Share This Page