File sharing in Windows a PITA as usual...

Discussion in 'Troubleshooting Help' started by MonoJoker, Oct 21, 2018.

  1. MonoJoker

    MonoJoker Member

    Joined:
    Jul 11, 2001
    Messages:
    2,537
    Location:
    An hour west of Brisvegas
    Hi All,

    Trying to share a D: drive on my Windows 7 Pro machine with a Windows 10 machine. The default public shares work fine as does any folder on the D: drive. But try to share D: and it's "Access Denied". I've found at least 5 "solutions" online that describe how to setup file sharing and pretty sure I'm doing all the steps:

    1. Enable sharing using Advanced Sharing because the usual "Share" button is not available for top level drive
    2. Share folder to Everyone giving Read and Change
    3. Set all sharing options to ON under Advanced properties under Network & Internet settings
    4. Turn OFF password protected sharing

    Nup, still get the standard message about not having permissions to access D on the remote computer.

    Has anybody got the "special" instructions for getting this to work? Bit tired of googling the same steps which don't work :)

    TIA
     
  2. broccoli

    broccoli Member

    Joined:
    Feb 21, 2010
    Messages:
    18,295
    Location:
    Perth
    Have you also put "everyone" in the security tab? There's a "sharing" tab and a "security" tab, you have to put it in both.
     
  3. ibace

    ibace Member

    Joined:
    Aug 10, 2015
    Messages:
    94
    Location:
    Bathurst NSW...
    Dunno if it is the reason for your issues...but M/S deleted the 'Homegroup' options in all Windows 10 installs in their last cumulative update. Wondered why all of a sudden my home network was gorn....Dr. Google provided the information...It is possible to allow share on a specific item on a WIn10 machine...but because the Homegroup is gone...there's no way to network that Win10 PC...enough reason for me to can Windows 10...
     
  4. philquad

    philquad Member

    Joined:
    Jan 22, 2004
    Messages:
    735
    Location:
    nelson bay
    i seem to have this problem
    1 folder has always worked as a share with public user folders
    but other wont, i just tried the everyone trick
     
  5. philquad

    philquad Member

    Joined:
    Jan 22, 2004
    Messages:
    735
    Location:
    nelson bay
    ibace, your a bloody genius
    all this time ive struggled with certain folders to share, just add user "everyone" & give that rights, they all work now lol
    who said you were stupid.

     
  6. RyoSaeba

    RyoSaeba Member

    Joined:
    Sep 11, 2001
    Messages:
    12,152
    Location:
    Perth
    After you share the folder/drive, go to the security and add the permission again. Then turn off firewall or add new rule in the firewall to make sure it's not blocked.
     
  7. koopz

    koopz Member

    Joined:
    Dec 27, 2001
    Messages:
    1,987
    Location:
    Qld
    I remember when Vista started with this level of end user added difficulty.

    we sold a lot of NAS drives back then ;)
     
  8. Recharge

    Recharge Member

    Joined:
    Sep 5, 2001
    Messages:
    9,007
    Location:
    Brisbane

    this is what you have to do, manually add "everyone"

    folder, properties, security : edit : add "Everyone" APPLY
    now sharing, advanced sharing : tick "share this folder" APPLY

    now works.

    share a drive is the same.
     
    Last edited: Oct 26, 2018

Share This Page