GTX 980Ti Gaming 1 6GB randomly dropping monitor into Power Saving Mode when gaming?

Discussion in 'Troubleshooting Help' started by GDavid, Aug 28, 2017.

  1. GDavid

    GDavid Member

    Joined:
    Apr 12, 2009
    Messages:
    1,345
    Location:
    ADL
    Purchased a Gigabyte Gaming GTX 980Ti 6GB from the forums and dropped it into my Win10Pro Z170 / i5-7600K and since adding the GPU my monitor randomly goes into "Power Saving Mode" mid-game.
    I cannot Alt-Tab or anything else to "wake" the monitor, but can still hear TS/Discord and all I seem to be able to do is reset the PC which is really doing my head in... :(
    I've tried all the Power setting I'm aware of within windows, but I'm no sysadmin...
    It's probably a simple one, but I'd really appreciate some help as this is the most expensive card I've ever owned and run...
     
  2. im late

    im late Member

    Joined:
    Jan 5, 2012
    Messages:
    1,117
    Location:
    Canning Vale WA 6155
    I am assuming you removed all drivers of the video card before installing the latest driver from nvidia?

    they should just drop in and work, bar driver conflicts.
     
  3. jamieyn

    jamieyn Member

    Joined:
    Aug 31, 2003
    Messages:
    436
    Location:
    Melbourne
    A few things to try:

    -it could be the card overheating
    Run something like HWmonitor to log the temps of the card - then run a looping benchmark perhaps?

    -it could be a cable thats marginal
    tried a different cable - maybe even a different sort (eg - you use DVI, try HDMI or displayport).

    -it could be a port on the card (I had a gigabyte 980ti - and one of the DVI ports was dodgy - try using the other).

    -your PSU is able to support the card?

    Good luck!
     
  4. Deano_20802

    Deano_20802 Member

    Joined:
    Apr 21, 2009
    Messages:
    286
    Location:
    Tas
    A number of great suggestions above mate, and I've sent you a PM :thumbup:
     
  5. OP
    OP
    GDavid

    GDavid Member

    Joined:
    Apr 12, 2009
    Messages:
    1,345
    Location:
    ADL
    Thanks guys, your advice was what helped me sort the issue. :thumbup:

    • Yes, I'd removed the drivers with DDU even though I was updating an earlier Nvidia card. :thumbup:
    • Good to see you again jamieyn :)
    • Monitoring software, but the display drop-outs were boning me and the temps were within range... :upset:
    • As suggested, tried cables ($19 DP but not the issue), even checked the HDMI, DVI-D to HDMI, DVI-D to DP, DVI-D, DP cables and ports... :Paranoid:
    • EVGA 850W G2 Supernova ought to be well within requirements too...

    The resolution by confession... I got a strange error message (regarding PCIE power) during a re-boot which led me to remove the case cover again: my dual 8 pin power cables from the PSU seemed to not be fully seated... :o
    The excuse... My PSU is way too big for my Temjin TJ08 case and I failed to seat the connections properly when changing the modular cables, luckily I was able to get a good seating by using a screwdriver against the back of the plug this time rather than my fingers...


    So thanks again for your help, you guys rock! :thumbup:
     
  6. Deano_20802

    Deano_20802 Member

    Joined:
    Apr 21, 2009
    Messages:
    286
    Location:
    Tas
    A pleasure to help, glad you got it sorted :thumbup:
     
  7. jamieyn

    jamieyn Member

    Joined:
    Aug 31, 2003
    Messages:
    436
    Location:
    Melbourne
    Glad its worked out! The 980ti is still a beast of a card - Enjoy! :thumbup:
     

Share This Page