SOLVED Micron SSD, WIN10 OS lock: Kernel-Power 41 - EnhancedStorage-EhStorTcgDrv

Discussion in 'Troubleshooting Help' started by Bold Eagle, Nov 24, 2016.

  1. Bold Eagle

    Bold Eagle Member

    Joined:
    Jun 28, 2008
    Messages:
    6,714
    Location:
    Brisbane
    For the last month I have had a major mind bending issue with my system going to a hard lock on the OS and either losing all functionality (no mouse or keyboard functions) or can move mouse but just keep having an activity wheel and nothing responds. The only solution was to restart or hard power off.

    This turned into a massive learning curve and after many hours (greater than 30) of system analysis I think I have finally isolated the issue.

    This was occurring at anytime (could be morning or night) and during any activities (gaming to web browsing to File Explorer, etc).

    It was observed that the SSD (Primary Boot) was at 100% when this occurred. That is after about the 20th crash I first noted the HDD activity light on the case was staying constant. Next I opened Task Manager and noted the SSD was at 100% and staying there.

    Event Viewer shows that I have 50 Critical events since 22/10/2016. These coincide with my system OS locks.

    They are all: Kernel-Power 41 (63);
    Reviewing the information flags before this event I found a driver that seems to be casual and after analyising the Windows System logs for the date/time stamps for the Critical Events I keep seeing:
    EnhancedStorage-EhStorTcgDrv
    Event ID: 12 or 100

    Click to view full size!


    Googling EnhancedStorage-EhStorTcgDrv a common theme started to appear:
    A lot of Micron Crucial SSD owners (they top the google search results) were experiencing this issue across many models of their SSD range. As my system has a Crucial M550 I also feel into this category.

    Issue:
    With Win10 my system was just using "Windows generic storage driver" for the IDE ATA/ATAPI controllers.

    Going to my mobo (Asrock z68 extreme4) website for Win10 drivers it only offered 3 and none of those were for for SATA/AHCI drivers and previously this system had worked fine with a different make of SSD for the last ~4 years without issue.

    Last night I went back and found the Marvell and Intel (RAID) SATA/ACHI chipset drivers, and although they were only listed upto Win7 OS I installed one (the Marvel as it was a exe) and then updated the other via Device Manager and have not had a system lock since (touch wood).

    In summary: from the forum posts I was reading it has to do with Win10 encryption (Bitlocker) wanting to over-ride the Crucial SSD Host Controller (HC) instructions.
    http://forum.crucial.com/t5/Crucial...TCG-Command-has-returned-an-error/td-p/149506

    I hypothesise that Win10 was providing the generic Standard SATA AHCI controller drivers - this was allowing Win10 to override the mobo chipset and then the Micron SSD Host Controller and causing the system lockups. By installing the mobo storage controllers - even though they had last been published for Win7 - it allowed the mobo chipset to control the storage drivers and not conflict with the Micron SSD HC. So far stability had persisted (3 days later).

    Edit: it has now been a week and this issue has not re-occurred.
     
    Last edited: Dec 2, 2016
  2. GDavid

    GDavid Member

    Joined:
    Apr 12, 2009
    Messages:
    1,345
    Location:
    ADL
    Thanks Bold'
     
  3. FOTW

    FOTW Member

    Joined:
    Jul 20, 2002
    Messages:
    745
    Location:
    Kilcock, Ireland
    Cheers thanks for that.

    Had similar issues with Intel SSDs Intel RST Driver and bitlocker conflicting as well.
     
  4. OP
    OP
    Bold Eagle

    Bold Eagle Member

    Joined:
    Jun 28, 2008
    Messages:
    6,714
    Location:
    Brisbane
    Nps I hope you can see how I found a method to follow to finally isolate a trend (EnhancedStorage-EhStorTcgDrv driver) and then to analyse that in detail and find a resolution.

    When using Event Viewer if you review the Event Viewer (Local) you will get a summary table of flags and then investigate from there:
    Running Event Viewer
    https://www.petri.com/vista-event-viewer
    Then noting down the date and time stamps of any Critical flags you may want to look what has occurred just before that may have caused a 'Critical' event leading to a system shut down.

    Windows Logs>System - sort by Date and Time.

    Hope it helped it seems like bitlocker is a lot more aggressive than it needs to be and is causing SSD lock ups.

    P.s. I did the Win10 upgrade to Creators Update - OS started having issues so I did a fresh install of CU and forgot about this issue and within a day had a Critical event again - reinstalled the drivers and no issue since (for the last 2 months).
     
    Last edited: Aug 25, 2017

Share This Page