Nforce2 Mobo Drivers and Vista.

Discussion in 'Windows Operating Systems' started by ZoLi, May 17, 2007.

  1. ZoLi

    ZoLi Member

    Joined:
    Sep 19, 2002
    Messages:
    414
    Location:
    Melbourne, Aus
    Hi All,

    Just install Vista the other night and Ive obviously noticed the problem that Nvidia is not support nforce1/2/3 chipsets anymore.
    I have been reading and found some forums advising that you can download the nforce4 vista drivers and only install the SMbus and IDE portion of the drivers and this will work.
    Does anybody know if this works?

    Thanks
     
  2. Saiyan_Overlord

    Saiyan_Overlord Member

    Joined:
    Jul 6, 2005
    Messages:
    2,007
    Location:
    Sydney 2074
    I thought most people were just using the generic vista drivers because nvidia isn't providing drivers for nforce1/2. I wouldn't have thought though that they would have dropped driver support for nforce3 under vista, think about all the people using Socket754 with nf3 and the 939 users with nf3.

    IIRC reading a while ago there were beta drivers release for nforce2 when vista was still in beta though I don;t know if anyone has been using them on retail/final release copies of vista.
     
  3. OP
    OP
    ZoLi

    ZoLi Member

    Joined:
    Sep 19, 2002
    Messages:
    414
    Location:
    Melbourne, Aus
    Yeah I noticed there was vista drivers for nforce3 on the nvidia site. msut have been some old forums I saw or they released drivers for the people complaining on nforce3 chipsets.

    I tried the nforce4 smbus driver anyways and killed the OS :)
    I now have to reformat but thats okay, guess I'll use the generic drivers but in Device manager is come us showing the smbus as being invalid or no driver. thats why I sort of started researching this thing.

    I'll see if I can find the nforce 2 beta drivers around.

    cheers
     

Share This Page

Advertisement: