P3V4X 'Lumping' IRQ 9

Discussion in 'Other CPUs and chipsets' started by johnnyriCo, Jul 8, 2001.

  1. johnnyriCo

    johnnyriCo New Member

    Joined:
    Jun 27, 2001
    Messages:
    170
    Location:
    Perth, WA
    Hey Guys!

    Recently get a p3v4x and am having a real BAD problem...

    No matter what I doall my devices (netcard, TNT2, Fasttrak, SBPCI64, Netcard, ACPI (?)) all get lumped on the same IRQ (number 9) and I can't rectify the problem...

    I have tried:
    Swapping around the cards into all sorts of configurations
    Manually setting IRQ's in Bios
    Disabling COM ports
    Setting in bios PNPOS = NO
    swapping RAM banks around (!)

    At the moment I am set up as follows.

    PNPOS = NO
    Comport = disabled
    IRQ assignments = auto
    TNT2 = AGP
    Fasttrak = Slot2
    SBPCI64 = Slot3
    Net card = Slot4

    Anyone have any ideas?
    as i am completely stumped!
    I am running 1005 (Says that during BIOS screen)

    PLS note... when I manually set the IRQ's in this configuration the PC locks up during the BIOS load screen (where is says INIT PNP cards)... It will not go into the bios and wont boot. Just sits there. The only way to fix it is to swap around a stick of RAM (swap banks) WIERD!

    PLS Note : running Win2k
    4.32 4 in 1's
    Latest Detonators.

    Anyone got any ideas?
    Anything would be appreciated.

    Thanx!
    ricos_rufnecks@hotmail.com
     
  2. snoopy

    snoopy Member

    Joined:
    Jun 26, 2001
    Messages:
    239
    Location:
    Sydney
    Hiya,

    I just spent a few hours fixing IRQ conflicts in win98 SE after replacing my pci video card with a GTS2 and then replacing my isa sound card with a pci sound card on my P3V4X.

    This is how I fixed it.

    Enable PNP and com ports in bios. (I have tried disabling it too and it did nothing).
    Put the sound card in slot 2, force it to use IRQ5 in bios. (I assume your IRQ 5 is free. On my pc, the bios and win98 just wouldn't pick it up for the sound card automatically)

    Put the fast trak in slot 4 (I have the scsi card here)
    Put the network card in slot 5.

    AND pray real hard.

    Good luck.

    PS, if it doesn't work, try reinstalling windows on top of your existing windows. It might cause windows to reassign all IRQs properly.

    Just noticed you're having problems with win2000 and not win98. OK, my win2000 has IRQ9 assigned to all the devices as well. Weird but everything works.
    So if it works, don't worry about it. Otherwise try the combo I sugested.
     
    Last edited: Jul 8, 2001
  3. h2k

    h2k Member

    Joined:
    Jun 27, 2001
    Messages:
    154
    Location:
    Canada
    With win2k, I had to make the bios set to no PNP os,
    and then when I reinstalled, the devices weren't all on irq 9. You might have to change your system from ACPI to Standard in win2k if this doesn't work.
     
  4. OP
    OP
    johnnyriCo

    johnnyriCo New Member

    Joined:
    Jun 27, 2001
    Messages:
    170
    Location:
    Perth, WA
    yer...

    Yer...
    The everything getting assigned to IRQ 9 is normal in win2k i found with acpi enabled.. (How do I disable it???)

    You see... I get sorta random hardware lockups (everything just stops no blue screen, it just freezes!)

    This happens seemingly randomly AND when I try to copy a whole heap of data over the network (7gb) Just locks while copying...

    To me SEEMS like an IRQ conflict!!!

    Any ideas?
    And... how do I get the IRQ's 'going'

    I think ill asssign the SB IRQ 5....
    hm.
    thanx
     
  5. h2k

    h2k Member

    Joined:
    Jun 27, 2001
    Messages:
    154
    Location:
    Canada
    If it just stops, have you tried to replace parts like ram, diff cpu, etc? I never actually had problems with everything on irq9, except with some crackling, but It's a crappy sound card anyway.
     
  6. OP
    OP
    johnnyriCo

    johnnyriCo New Member

    Joined:
    Jun 27, 2001
    Messages:
    170
    Location:
    Perth, WA
    update

    Yer.
    Ive tried swapping around the cards into different slots...
    No Joy.. will ALWAYS lock up when trying to transfer heaps of data... :(

    don't have a clue to the problem.
    Anyone know how to disable ACPI?
    might give that a try...
     
  7. Chief

    Chief Member

    Joined:
    Jun 29, 2001
    Messages:
    83
    Location:
    Melbourne
    Am having the same problems Johnny.

    Is there any way of disabling acpi without reinstalling win2K?

    Any help greatly appreciated! :)
     
  8. Whisper

    Whisper Member

    Joined:
    Jun 27, 2001
    Messages:
    8,297
    Location:
    Sydney
    Assign PCI Slot 1 to IRQ 9
    Assign PCI Slot 2 to IRQ Auto
    Assign PCI Slot 3 to IRQ 10
    Assign PCI Slot 4 to Auto

    Disable the Serial Ports
    Disable or set to Auto the PS/2 Mouse port if you can.

    Do not try to assign IRQ12 to anything, regardless of whether you have a PS/2 Mouse or not.

    In the boot option menu, enable the option to update devices.

    Let me know how you go.

    Cheers
     
  9. scummer

    scummer Member

    Joined:
    Jun 28, 2001
    Messages:
    16
    Location:
    Michigan
    I read somewhere that when you install the OS, the 4 in 1 drivers need to be installed before any other hardware devices are installed in the system. I guess Win 2000 doesn't exactly know how to deal with the chipset and uses only one IRQ. My next move would be to remove all devices execpt video, install the 4 in 1's then reinstall the hardware. It might be easier just to format and reinstall the OS if you havn't got too much time on your current install.

    ASUS P3V4X, Apollo Pro133A,1005 bios
    Step ThermoDynamics PIII 700 @ 933 1.90 vcore
    Promise Fasttrack 100 (raid 0)
    2x IBM GXP75
    SB Live Platinum
    256 meg Crucial cas2 ram
    Pioneer 115 DVD
    Plextor 16/10/40A CDRW
    Utobia DVD decoder with Remote
    ZIP Drive
    Netgear nic
    WIN ME
    Radeon 32DDR clocked 187MHz
     
  10. OP
    OP
    johnnyriCo

    johnnyriCo New Member

    Joined:
    Jun 27, 2001
    Messages:
    170
    Location:
    Perth, WA
    irq...

    About that using only one irq...

    i dont think it really works like that..

    windows just reports that it only uses one irq.. but it dynamically assigns around the unused irqs...

    so it doesn't really matter that it reports that only one irq is being used...

    as long as its stable.
    but mine isn't... Network cards causes lockups..
    or maybe its the raid card :(
    anyway..
    trying what whisper said...
     
  11. MWP

    MWP Member

    Joined:
    Jun 27, 2001
    Messages:
    4,632
    Location:
    Adelaide
    If you have a truly compilant ACPI bios (like most do) Win2K will put all PCI cards on IRQ9 no matter what you do.

    But there is one way to fix it. Turn off ACPI support in Win2k.
    This will kill off a few MB functions tho... the power button will no longer work like normal, windows will not power off the PC on shutdown and suspend/etc will not work. Hardware monitoring im 90% sure will still work tho.
    But if you are determined to stick to Win2K and fix the IRQ9 problem, these are easy things to live with.

    (im doing this from memory here, so this prolly wont be exactly right)
    Device Manager.
    The first device in the list should be somthing like "Computer Management". In there will be a listing with ACPI in the name (easy to find).
    Select it, edit properties and select "uprgrade drivers".
    Select choose from list and then in the list select "all devices".
    In there should be listed the driver that your changing from.
    Select "Simple Computer" (eeek, i think its called that) and hit ok.

    (can someone verify this, i would but im running 98 now :) ??)

    After that, if you have PnP OS in the bios set to no, youll be able to give all your PCI slots IRQ addrs which will then apply under WIN2k.
     
  12. OP
    OP
    johnnyriCo

    johnnyriCo New Member

    Joined:
    Jun 27, 2001
    Messages:
    170
    Location:
    Perth, WA
    yerpo

    I think whispers advice did it..
    will have to test it further.
    but it now seems to 'freeze' but not lock up.
    just go jerky a bit sometimes during copying that whole pile of stuff..
    can't be bothered waiting th 20 mins for it to finish.
    but went through some way pretty well...
     
  13. Whisper

    Whisper Member

    Joined:
    Jun 27, 2001
    Messages:
    8,297
    Location:
    Sydney
    Good to hear.

    Also I would advise turning "PNP OS Installed" to Enabled.

    Also everybody is assuming you are using Windows 2000, I afraid I missed that part of you part and can not see where you say what OS you are using?
     
  14. Squozen

    Squozen Member

    Joined:
    Jun 27, 2001
    Messages:
    46
    Location:
    Melbourne, Aust
    irqs

    If you have problems with IRQ conflicts, just move the cards themselves around, don't try reassigning the IRQs.

    Network cards especially are tetchy about where they want to sit. Experiment.



    --
    S
     
  15. vinnY

    vinnY Member

    Joined:
    Jun 27, 2001
    Messages:
    1,983
    Location:
    sydney.nsw.au
    take out any isa cards, then look at the irqs.
     
  16. Dave H

    Dave H Member

    Joined:
    Jun 30, 2001
    Messages:
    21
    Location:
    Arlington, Va. USA
    Aaah--The old "Win 2K, It's All On IRQ 9" problem.
    Here is some info from a while back and to the best of my knowledge it's still valid:

    Here is an article that I found in TechNet on IRQ sharing...
    IRQ Sharing in Windows 2000

    --------------------------------------------------------------------------------
    The information in this article applies to:

    Microsoft Windows 2000 Professional
    Microsoft Windows 2000 Server
    Microsoft Windows 2000 Advanced Server

    --------------------------------------------------------------------------------


    SUMMARY
    In Windows 2000, peripheral component interconnect (PCI) devices can share interrupts (IRQs) by design. Per the Plug and Play capability that is defined by the PCI specification, adapters are configured by the computer's BIOS, and are then examined by the operating system and changed if necessary. It is normal behavior for PCI devices to have IRQs shared among them, especially for Advanced Configuration and Power Interface (APCI) computers with Windows 2000 ACPI support enabled.

    MORE INFORMATION
    In Windows 2000, some or all of the devices on your ACPI motherboard may be listed on the Resources tab in Device Manager as using the same IRQ (IRQ 9). You cannot change the IRQ setting because the setting is unavailable. This occurs because Windows 2000 takes advantage of the ACPI features of the motherboard, including advanced PCI sharing. IRQ 9 is used by the PCI bus for IRQ steering. This feature lets you add more devices without generating IRQ conflicts.

    Note that Windows 2000 does not have the ability to rebalance resources as does Microsoft Windows 98. Once PCI resources are set, they generally cannot be changed. If you change to an invalid IRQ setting or I/O range for the bus that a device is on, Windows 2000 cannot rebalance the resource it assigned to that bus to compensate. Windows 2000 does not have this ability because of the more complex hardware schemas it is designed to support. Windows 98 does not have to support IOAPICs, multiple root PCI buses, multiple-processor systems, and so on. Rebalancing becomes risky when you are dealing with these hardware schemas, and will not be implemented in Windows 2000 except for very specific scenarios. However, PCI devices are required to be able to share IRQs. The ability to share IRQs should not prevent any hardware from working in general.

    The Plug and Play operating system settings in the computer's BIOS should not affect how Windows 2000 handles the hardware in general. However, Microsoft recommends that you set this setting to "No" or "Disabled" in the computer's BIOS. For information about viewing or modifying your computer's BIOS settings, consult your computer's documentation or manufacturer. Manually assigning IRQs to PCI slots as a troubleshooting method may work on a non-ACPI system, but these settings are ignored by Plug and Play in Windows 2000 if ACPI support is enabled. If you need to manually assign IRQ addresses to a device on an ACPI motherboard, disable ACPI in the computer's BIOS before installing Windows 2000.

    Additional query words:

    Keywords : kbhw w2000device w2000pnp
    Version : WINDOWS:2000
    Platform : WINDOWS
    Issue type : kbinfo
    Technology :


    It can be found on the web at http://support.microsoft.com/support/kb/articles/Q252/4/20.ASP?LN=EN-US&SD=gn&FR=0


    Hey, do disable IRQ sharing in Windows2000 U need 2 install a new driver under the devicemanager.. the current driver installed is "ACPI Compliant system" but U need 2 install Standart PC" instead.. then upon reboot Win2K will re-detect your hardware with correct IRQ's.. Hope U understand this cause i'm 2 freaking tired 2 post replys.


    And here is a little more that was posted previously on the site as well:

    I now have it working perfectly thanx to deadeyedans post a little while back which wasTry this
    This is a 'feature' of Windows 2000 - it uses ACPI in such a way that all devices share the same IRQ, usually 9 or 11. If you don't have problems, then leave it alone, but if you do get problems, use one of the procedures below:
    This procedure, submitted by Steve Aucoin, will allow you to disable ACPI without reformatting:
    Disable P&P OS and ACPI in your BIOS, if you can - if the option is not available try installing the latest BIOS update for your motherboard. You can get help with finding out what BIOS you need and instructions as to how to flash it at Wim's BIOS page
    Reboot. Go to Control Panel - Hardware and double click on My Computer in the hardware manager.
    You'll see ACPI - get into its properties and click to install another driver. When prompted, look under the Microsoft section and install the "Standard PC" driver.
    Reboot. At this point Win2k will try and reinstall all devices on your system so install any drivers you are prompted for (have them all handy) and reboot. Finalise any drivers you may be prompted for on the 2nd boot and reboot again.
    With all your drivers re-installed, take a look in hardware manager - and every device should have its own IRQ.

    Now works great, stupid bloddy microshaft


    I hope this is helpful to you!
    Dave H
     
  17. auenf

    auenf Member

    Joined:
    Jun 28, 2001
    Messages:
    373
    Location:
    South Camden NSW
    with ACPI, the devices ARENT sharing the one irq.

    ACPI is a new mobo feature that basically removes the 15 IRQ limitation and altho it apears that the devices are sharing an irq (with the ACPI controller), the ACPI controller is actually giving the devices their own IRQ.

    If you have NO problems, then leave it be, and i can assure you that most problems that you may think are IRQ conflicts, wont be.

    if you have a problems, tell us and you may find you're barking up the wrong tree

    Enf...
     

Share This Page

Advertisement: