Router Crashes (Need Cisco Guru's as it turns out).

Discussion in 'Networking, Telephony & Internet' started by neutralizer, Jun 12, 2008.

  1. neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    Hi Guys,

    I'm looking for a new router that won't crash so much with Utorrent.
    I know all the things to try disabling DHT and UPnP and reducing connections etc. None of them helped.

    Currently I live a long way (like 6km cable distance) from the exchange, is their any point looking into ADSL2+ at this distance?

    Either way, what router can you recommend (I connect to a wired home LAN) that is reliable for running torrents with the above features enabled and is still reasonably secure.

    Also what firmware would you advise to use with it?

    EDIT: Sorry, I forgot to mention, I currently have a Cisco 837.

    Cheers
     
    Last edited: Jun 12, 2008
  2. TTV6

    TTV6 (Banned or Deleted)

    Joined:
    Sep 24, 2007
    Messages:
    148
    Location:
    Sydney
    what router have youg ot atm
     
  3. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    A Cisco 837
     
  4. phreeky82

    phreeky82 Member

    Joined:
    Dec 10, 2002
    Messages:
    9,470
    Location:
    Townsville
    I'm surprised that router is dying just from torrents. Is there a setting for max number of simultaneous connections that you can alter? Or is the router actually running out of memory or something similar? I would definitely look into the cause of it first.
     
  5. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    Yeah I've been using it without the SDM, but I think I might try and get and SDM capable IOS that might solve some of the problems.
     
  6. evilasdeath

    evilasdeath Member

    Joined:
    Jul 24, 2004
    Messages:
    4,782
    Isn't SDM just a configutrator tool, not anythign special really?

    I am surprized that it wouldn't be able to handle a large number of connections since you would only be default routing so you don't require much processor at all other than to remember the sockets. Is it actually crashing? crash log and all? whats the log telling you? maybe a bit of debugging is needed.

    I would think it would be just running simple DHCP?
     
  7. leighr

    leighr Member

    Joined:
    Feb 28, 2002
    Messages:
    558
    Location:
    Richmond, Melbourne
    Post up the router config so that the Cisco gurus here can suggest some changes to it.

    Leigh.
     
  8. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    Yep cheers. Here's the config at the moment:

    Code:
      encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
     dsl operating-mode auto
     hold-queue 208 in
    !
    interface Dialer0
     ip address negotiated
     ip nat outside
     ip access-group 111 in
     ip inspect myfw out
    encapsulation ppp
     dialer pool 1
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname ******
     ppp chap password ******
    !
    ip nat inside source list 8 interface Dialer0 overload
    ip nat inside source static tcp 10.1.11.101 49500 interface Dialer0   encapsulation aal5mux ppp dialer
      dialer pool-member 1
     !
     dsl operating-mode auto
     hold-queue 208 in
    !
    interface Dialer0
     ip address negotiated
     ip nat outside
     ip access-group 111 in
     ip inspect myfw out
    encapsulation ppp
     dialer pool 1
     no cdp enable
     ppp authentication chap callin
     ppp chap hostname ******
     ppp chap password ******
    !
    ip nat inside source list 8 interface Dialer0 overload
    ip nat inside source static tcp 10.1.11.101 49500 interface Dialer0 *****
    ip nat inside source static udp 10.1.11.101 49500 interface Dialer0 *****
    ip nat inside source static udp 10.1.11.101 6257 interface Dialer0 *****
    ip nat inside source static tcp 10.1.11.101 6699 interface Dialer0 *****
    ip nat inside source static udp 10.1.11.101 4828 interface Dialer0 *****
    ip nat inside source static tcp 10.1.11.101 4840 interface Dialer0 *****
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer0
    no ip http server
    !
    !
    access-list 23 permit ****** ******
    !
    access-list 8 permit ****** ******
    !
    access-list 111 permit udp any any eq *****
    access-list 111 permit tcp any any eq *****
    access-list 111 permit udp any any eq *****
    access-list 111 permit tcp any any eq *****
    access-list 111 permit udp any any eq *****
    access-list 111 permit tcp any any eq *****
    access-list 111 deny   udp any any eq netbios-ns
    access-list 111 deny   udp any any eq netbios-dgm
    access-list 111 deny   udp any any eq netbios-ss
    access-list 111 deny   icmp any any echo
    access-list 111 permit icmp any any administratively-prohibited
    access-list 111 permit icmp any any echo-reply
    access-list 111 permit icmp any any time-exceeded
    access-list 111 permit icmp any any unreachable
    access-list 111 deny   ip 10.0.0.0 0.255.255.255 any
    access-list 111 deny   ip 172.16.0.0 0.15.255.255 any
    access-list 111 deny   ip 192.168.0.0 0.0.255.255 any
    access-list 111 deny   ip 127.0.0.0 0.255.255.255 any
    access-list 111 deny   ip host 255.255.255.255 any
    access-list 111 deny   ip host 0.0.0.0 any
    access-list 111 deny   ip any any log
    !
    dialer-list 1 protocol ip permit
    !
    !
    banner login 
    //////////////////
    /                /
    /    cisco837    /
    /     ******     /
    /                /
    //////////////////
    
    !
    line con 0
     exec-timeout 0 0
     password ******
     login local
     no modem enable
     stopbits 1
    line aux 0
     stopbits 1
    line vty 0 4
     access-class 23 in
     exec-timeout 0 0
     password ******
     login local
    !
    scheduler max-task-time 5000
    end
     
    Last edited: Jun 12, 2008
  9. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    Yeah SDM is just a configurator tool, but given how well my version of a config is working I seem to need it :D
     
  10. evilasdeath

    evilasdeath Member

    Joined:
    Jul 24, 2004
    Messages:
    4,782
    you haven't defined how its crashing? or whats happening when its crashing logs etc.

    CPU time? mem usuage? or is your dsl just going down cos of poor line qual and a reboot brings it up again.

    crashing is very vague.
     
  11. SpudBoy

    SpudBoy Member

    Joined:
    Jul 30, 2001
    Messages:
    5,262
    Location:
    Under the Bed.
    i wonder if it uses the same cpu as the Linksys BEFSR41 (knowing that cisco own linksys) as it is the only other router i have heard of that simply locks up as soon as you start a torrent.

    this is the ONLY time the BEFSR41 crashes. and it seems to have a lot to do with the sheer number of connections torrents generally make.

    I have noticed that it doesnt crash using the Opera browser's integrated torrent engine though.
    but azureus, utorrent ect... blam.. dead.
     
  12. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    Okay its purely related to bit torrent running except on very odd (once or twice a year).

    Basically the RXD and TXD lights lock up before it loses carrier detect. It then takes about 3-5 mins to regain CD with a further 15-30 seconds before it will start to transmit again.
    Where does it output its error log to?
     
  13. SpudBoy

    SpudBoy Member

    Joined:
    Jul 30, 2001
    Messages:
    5,262
    Location:
    Under the Bed.
    sounds VERY similar to the problem with the BEFSR.
    i found that powercycling the device is usually quicker then waiting for it to unlock itself.

    not sure what i can do to help, mebbe google around and see if other people have had similar issues with your router.


    pity it cant help me, as there is NO cure for the BEFSR4.1 other then a mallet.
     
  14. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    I'm wondering if it could be my ISP dropping the session from their end, is it possible that they could decide to flip the switch because they hate bit torrent and simply have a set of criteria that defines what it considers to be an active torrent which then automatically terminates the session.....

    Currently I'm with TSN.
     
  15. SpudBoy

    SpudBoy Member

    Joined:
    Jul 30, 2001
    Messages:
    5,262
    Location:
    Under the Bed.
    havent really heard anything like that happening..

    would think that would be unlawful as they cant say if the torrent is legit or not.
     
  16. evilasdeath

    evilasdeath Member

    Joined:
    Jul 24, 2004
    Messages:
    4,782
    i think you have to enable it on the 837s with the command
    logging buffered

    then you can do a show log at any time to show you the current log, this will wipe on a power cycle so if you are leaving it on to re-connect then you should see it all.
     
  17. ewok85

    ewok85 Member

    Joined:
    Jul 4, 2002
    Messages:
    8,074
    Location:
    Tokyo, Japan
    Don't care about distance, whats your attenuation/SNR? That will tell me far more about your line.
     
  18. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    That command doesn't seem to work.

    The most likely candidates are:
    debug
    show
    monitor

    'monitor' does not seem to work it says: % incomplete command

    Show has a million options, one of which is
    show logging - that produces a bunch of stuff, what particular info might I be looking for?

    debug also has a lot of options but again, not sure what it is that I'm actually looking for...
     
  19. OP
    OP
    neutralizer

    neutralizer Member

    Joined:
    Mar 26, 2003
    Messages:
    1,405
    Location:
    Sydney
    To be honest mate I can't quite remember.
    I know its high, at least 54db, but possibly up near 60db.
    Any idea who I can chase to get a number on that?
     
  20. ewok85

    ewok85 Member

    Joined:
    Jul 4, 2002
    Messages:
    8,074
    Location:
    Tokyo, Japan
    Also, what is your utorrent settings? Number of connections, etc etc. Details! :D
     

Share This Page