So my Corsair PSU is sparking!

Discussion in 'Troubleshooting Help' started by THE D, May 2, 2012.

  1. THE D

    THE D Member

    Joined:
    Oct 5, 2004
    Messages:
    740
    Yesterday evening the Corsair HX650 PSU in one of the PCs in the house started making a crackling noise :sick:, the PC did not crash but it was shut down right away (note that I was on a different PC at the time in another room).

    Any attempt to turn the system back on has meet with 1 long beep and 3 short, no display (sometimes it does not beep) and sometimes a crackling sound and burning smell from the PSU.

    The system is an ASUS P5B with a E4300 CPU, two DDR2 DIMMs and a GTX260.
     
    Last edited: May 2, 2012
  2. Psychotria

    Psychotria (Banned or Deleted)

    Joined:
    Apr 26, 2012
    Messages:
    443
    Geez :shock: Doesn't sound good

    I actually quite like the smell of ozone though. Umm, not that this helps with your problem; sorry :(
     
  3. Jim G

    Jim G Member

    Joined:
    Jun 20, 2010
    Messages:
    1,011
    Location:
    Newcastle
    At this point I'd be taking the PSU out and RMA'ing it if it were in warranty or separately testing/binning it otherwise - I wouldn't try turning it on while it was connected to any components you valued just in case it blew something.
     
  4. OP
    OP
    THE D

    THE D Member

    Joined:
    Oct 5, 2004
    Messages:
    740
    Yeah, I was not the person that turned it back on the first time and because it did not make the crackling for the first few times it was turned back on I tried to get it to boot up.

    I do know that it did not blow the GFX card (the one thing I owned in that PC).
     
  5. Yamunsa

    Yamunsa Member

    Joined:
    May 24, 2009
    Messages:
    1,651
    Location:
    Cairns
    rma time... don't plug it in to anything else ever.
     
  6. OP
    OP
    THE D

    THE D Member

    Joined:
    Oct 5, 2004
    Messages:
    740
    Wasn't really planing to.

    Just that someone else heard the first sound and shut it down then I pulled a few things out to have a lot and then he put it back together without asking me.
     
  7. Yamunsa

    Yamunsa Member

    Joined:
    May 24, 2009
    Messages:
    1,651
    Location:
    Cairns
    confused what the question was then lol. you've posted in the Troubleshooting Help section. did you need assistance to start the rma?
     
  8. peteed1985

    peteed1985 Member

    Joined:
    Feb 23, 2009
    Messages:
    735
    Umm tbh that sounds an aweful lot like when a roach walked into my PSU >_>
     
  9. OP
    OP
    THE D

    THE D Member

    Joined:
    Oct 5, 2004
    Messages:
    740
    Umm, More like does anyone know what the beeps mean (can not fine the POST codes) and is it likely that the system is still good (bar the PSU) if nothing looks to have popped or burnt on the motherboard.
     
  10. OP
    OP
    THE D

    THE D Member

    Joined:
    Oct 5, 2004
    Messages:
    740
    Well I replaced the PSU and it seems the POS took out the RAM or RAM slots :thumbdn:
     

Share This Page