[SOLVED] Can't connect to Samba share

Discussion in 'Apple Desktop Hardware/Software' started by GooSE, Jul 22, 2011.

  1. GooSE

    GooSE New Member

    Joined:
    Jun 26, 2001
    Messages:
    6,679
    Location:
    Sydney
    Before we start I must admit that I'm quite new to Macs, but I'm fairly sure that it's not something simple that I've overlooked.

    Basically, I have a FreeBSD server that runs Samba to share files over the network using SMB. At the moment there are two shares; "videos" which allows guest access and "tank" which requires a username and password.

    Accessing both of these shares from Windows PCs, and also from my Android phone, is fine. The problem is accessing them from my MacBook Pro (running OSX 10.6.8). I can access "videos" fine (as a guest) but I cannot access the password protected "tank" share.

    I've tried accessing the share through finder (Go -> Connect to Server -> smb://10.0.0.10/tank) and while it prompts me for my username and password, no matter what it says "invalid username or password".

    I've also tried accessing the share from the command line (mount_smbfs //myusername:mypassword@10.0.0.10/tank /blah/blah) where I get "mount_smbfs: mount error: /blah/blah: Authentication error.

    I'd rather not resort to setting up NFS or AFP on the server, as that simply side-steps the problem rather than fixing it.

    So... Does anyone have any ideas?
     
    Last edited: Jul 27, 2011
  2. luztra

    luztra Member

    Joined:
    Apr 17, 2006
    Messages:
    40
    Location:
    Western Australia
  3. OP
    OP
    GooSE

    GooSE New Member

    Joined:
    Jun 26, 2001
    Messages:
    6,679
    Location:
    Sydney
    Thanks for the post, but it is essentially unrelated to my issue. I'm trying to access a Samba share from a Mac, not trying to access a Samba share that's on a Mac.
     
  4. BAK

    BAK Member

    Joined:
    Jan 7, 2005
    Messages:
    1,214
    Location:
    MornPen, VIC
    Like you I'm quite new to Macs, but one thing that springs to mind. Specify the domain the username belongs to - in this case it may be the hostname of the BSD box. So when typing in your username, it would be:

    hostname\username
     
  5. bugayev

    bugayev Whammy!

    Joined:
    May 15, 2003
    Messages:
    4,093
    Location:
    Melbourne
    That could well be it.

    What are the logs on your BSD box showing - is the mac sending the correct credentials?
     
  6. OP
    OP
    GooSE

    GooSE New Member

    Joined:
    Jun 26, 2001
    Messages:
    6,679
    Location:
    Sydney
    It gives an authentication error of some sort, so I guess not. I can't give the exact error as I don't have access to the box at the moment.

    Thanks, BAK. The server's name is simply FREEBSD, so I'll try enter the username as FREEBSD\myusername.
     
  7. [KEi]SoVeReIgN

    [KEi]SoVeReIgN Member

    Joined:
    Feb 20, 2002
    Messages:
    8,587
    Location:
    Sydney
    Try this - Find your smb.conf file (\etc), make an insignificant change and resave it.

    Have you tried mounting with cifs? What version of samba does freebsd use? The other avenue would be authentication settings, not sure what freebsd supports (ntlm etc)
     
    Last edited: Jul 25, 2011
  8. OP
    OP
    GooSE

    GooSE New Member

    Joined:
    Jun 26, 2001
    Messages:
    6,679
    Location:
    Sydney
    Make an insignificant change to smb.conf on the FreeBSD computer, or the MacBook? Also, I don't understand what you mean by "mounting with cifs" - as far as I'm aware SMB and CIFS are the same thing.

    I'm using Samba 3.5.something on the FreeBSD PC.
     
  9. OP
    OP
    GooSE

    GooSE New Member

    Joined:
    Jun 26, 2001
    Messages:
    6,679
    Location:
    Sydney
    Solved it.

    Mac OSX doesn't seem to like "security = share" in my server's Samba configuration. I reconfigured everything to work with "security = user" and now it's all working fine.
     

Share This Page

Advertisement: