1. OCAU Merchandise is available! Check out our 20th Anniversary Mugs, Classic Logo Shirts and much more! Discussion in this thread.
    Dismiss Notice

Strange mouse behaviour in Ubuntu after switching to 4k screen

Discussion in 'Other Operating Systems' started by daehenoc, Jun 5, 2022.

  1. daehenoc

    daehenoc Member

    Joined:
    Nov 4, 2005
    Messages:
    3,000
    Location:
    Mt Gravatt E, BNE, QLD
    Hi all,

    I'm having a strange problem with my mouse on Ubuntu, and I hope that someone can point me in the right direction to fix it!

    What happened was:
    • I installed Ubuntu 22.04 on my new MythTV hardware, with a 24" 1080 screen, and the mouse worked just fine, was responsive and moved how I expected it to move,
    • I recently moved the box back into the garage with a 32" 4k screen, and the mouse controls has gone badly;
    • Moving the mouse causes the cursor to erratically jump, like the sensitivity of the cursor is negative a billion, slowly moving the mouse results in the cursor being still... being still.. being stillllll..... then it jumps a centimeter on the screen,
    • Moving the mouse fast results in a jerky jumping motion of the cursor.
    As you can imagine, this make it pretty bloody hard to use X, and frustrating as hell. I replaced the mouse, same deal. Rebooted, same deal. I plugged the mouse into a different USB port (first and second mice are wired), same deal. Rebooted, same deal. Mouse Speed of the mouse is max in Settings.

    Does anyone have any ideas about what to look at or try? Everything I've found while searching das Interwebs is 6-10 years old, (irrelevant), or is one of the fixes I have already tried.

    I am open to anything, even sacrifices to our noodly god!
     
    Last edited: Jun 5, 2022
  2. HyRax1

    HyRax1 ¡Viva la Resolutión!

    Joined:
    Jun 28, 2001
    Messages:
    7,977
    Location:
    At a desk
    I presume it's not doing this in a live environment?

    Do you have a spare drive to do a quick clean install to see if the problem repeats itself?

    Do other USB devices exhibit symptoms of interference?
     

Share This Page

Advertisement: