1. OCAU Merchandise is available! Check out our 20th Anniversary Mugs, Classic Logo Shirts and much more! Discussion in this thread.
    Dismiss Notice

Trying to connect OS X to Samba share under Ubuntu.

Discussion in 'Other Operating Systems' started by flu!d, Apr 30, 2016.

  1. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    There's nothing in the log file at all.

    I tried uploading the log to paste.ubuntu.com but it appears it doesn't like uploading an empty file.

    [​IMG]
     
  2. elvis

    elvis Old school old fool

    Joined:
    Jun 27, 2001
    Messages:
    46,323
    Location:
    Brisbane
    You've missed the slash before "var" in your pluma command.

    I'm not sure what user Samba writes logs out as. You may need root permission to view the logs.

    Try this:

    1) run "sudo su -" to become root permanently (no need to prefix commands with "sudo" after that.

    2) cd /var/log/samba

    3) Use "less" to view files (and "q" to quit out of less).
     
  3. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    Edited the above post as I submitted the wrong screenshot. Sorry guys, I've got a 6yo daughter in my ear singing and dancing, struggling to focus here...
     
  4. elvis

    elvis Old school old fool

    Joined:
    Jun 27, 2001
    Messages:
    46,323
    Location:
    Brisbane
    I think someone mentioned it before too, but if your share name is "blah", then try connecting to

    smb://192.168.0.13/blah

    From OSX (i.e.: directly to the share). Sometimes trying to get a list of all shares causes problems.
     
  5. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    Bloody forward slash!

    Here you go Elvis, nothing in the log file:

    [​IMG]
     
  6. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    I tried connecting directly to the share using cifs://precisiont5500/complete (substitute smb if you wish, it makes no difference) in order to point directly at the share just in case it was trying to authenticate root, no good sadly.

    [EDIT] Above screenshot taken as root.

    [​IMG]
     
    Last edited: May 2, 2016
  7. elvis

    elvis Old school old fool

    Joined:
    Jun 27, 2001
    Messages:
    46,323
    Location:
    Brisbane
    Hrm, well, back to some connectivity testing then.

    Can you SSH to the Linux box from the Mac? Can you ping in both directions?

    And for more complex testing, see if nmap can see Samba listening as per the earlier post.
     
  8. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    Sorry Elvis, I'm gonna have to put my daughter to bed.

    You are a great help though, thank you so much. Is it ok if we continue tomorrow if you're around?

    I did mention it further back in the thread, I can ping no worries in both directions:

    Dell > Mac
    Mac > Dell.
     
  9. ^catalyst

    ^catalyst Member

    Joined:
    Jun 27, 2001
    Messages:
    12,011
    Location:
    melbourne
    Yeah, make sure you've got openssh going on your linux box, with any luck in mac term you should be able to just 'ssh $ip' and see what happens.
     
  10. elvis

    elvis Old school old fool

    Joined:
    Jun 27, 2001
    Messages:
    46,323
    Location:
    Brisbane
    Yeah, no problems. I've got a tribe of my own. Love them to bits, but boy they're a handful. :)
     
  11. ex4n

    ex4n Member

    Joined:
    Oct 5, 2011
    Messages:
    2,242
    Location:
    Perth
    maybe something simple, are you specifying a domain in your user credentials? eg. nas.hostname\smb.user

    can you see the ubuntu server in your list of network computers?
    is your mac on the same workgroup as the rest of the devices?
    system pref -> network -> advanced -> WINS

    I think this has to be done per interface too, so if you have wifi and cable, you may have to set the workgroup for both.

    just a few things i didn't see suggested yet.
     
  12. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    None of the devices in question are part of a domain, all a part of the default WORKGROUP and have checked WINS settings on the Mac to ensure it is on the same workgroup.

    Yes, I can see the Ubuntu server in the list of networked devices, I can connect to the Ubuntu server I just cannot authenticate login credentials for some reason.

    I remember doing this under Yosemite and I never had an issue?

    Mac:

    [​IMG]

    Ubuntu:

    [​IMG]
     
    Last edited: May 3, 2016
  13. ex4n

    ex4n Member

    Joined:
    Oct 5, 2011
    Messages:
    2,242
    Location:
    Perth
    I'm probably on the wrong track then, that all seems fine. Even if you're not on a domain, you still sometimes need to specify the 'domain' which you are logging onto, I find this is especially true in cross-os situations. If you have the same username on ubuntu\mac then sometimes you could be trying to connect to the NAS as mac\username not nas\username. Whenever I connect to my nas - I always use nas\username + password.

    one other random thought, does this kind of thing still work?
    Code:
    smb://WORKGROUP;user:password@ip_address/Share
     
  14. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    Aw damn it, I forgot about that command context and got all my hopes up, alas it didn't work.

    I'm flat out working ATM, as soon as I get a sec I'll try logging in via SSH to double check my login credentials as that seems to be what's tripping things over - Although I know they're correct as I've checked them a million times.
     
  15. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    Ok, this just gets weirder,

    As can be seen by the screenshot below I can SSH into the Ubuntu machine just fine, so nothing wrong with credentials.

    I'm sorry, but OS X is a joke.

    [​IMG]
     
  16. dave_dave_dave

    dave_dave_dave Member

    Joined:
    Mar 17, 2004
    Messages:
    2,917
    Location:
    Gold Coast
    I have an easier solution. Bootcamp it to windows.


    :lol:
     
  17. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    No shit. ;)

    But then I'd just be inundated with Malware...

    For the record, It can find a share on a Windows box just fine.
     
  18. ex4n

    ex4n Member

    Joined:
    Oct 5, 2011
    Messages:
    2,242
    Location:
    Perth
    Ok how about this...
    Open a shell, and
    Code:
    mount -t smbfs //username:password@hostname/sharename /mount/point
    Maybe also chuck in a --verbose switch if it's supported.

    edit: also, can't believe I didn't think of this sooner. Have you tried turning it off and on again?
    [​IMG]

    :p we've tried everything else.
     
    Last edited: May 3, 2016
  19. OP
    OP
    flu!d

    flu!d Never perfect, always genuine

    Joined:
    Jun 27, 2001
    Messages:
    20,464
    Go over the command, I'm pretty sure it's correct. Sadly, that didn't work...

    [​IMG]

    Love the comment "Have you tried turning it off and on!" :)
     
  20. ex4n

    ex4n Member

    Joined:
    Oct 5, 2011
    Messages:
    2,242
    Location:
    Perth
    does /media/Storage exist - remembering it's case sensitive?
     

Share This Page

Advertisement: