1. OCAU Merchandise is available! Check out our 20th Anniversary Mugs, Classic Logo Shirts and much more! Discussion in this thread.
    Dismiss Notice

Varying Audio Levels is driving me nuts

Discussion in 'HTPC' started by bejay, Jan 6, 2013.

  1. bejay

    bejay Member

    Joined:
    Oct 13, 2009
    Messages:
    260
    Location:
    Brisbane, QLD
    Ok, My i3 based HTPC is connected to Panasonic TV through Onkyo TX-SR706 AV receiver. I use XBMC for my media library and bitstream through HDMI audio. I can't remember what build of XBMC it is, but its not eden, its one of the nightly builds that does give the option of HD Audio. What is currently annoying the crap out me is the fact that the conversations sound very low and all the action is blaring. I don't know if my hearing is fucked or its just every one in the movies these days fuckin mumble. I have gone into Onkyo setup and have raised the center speaker level to max, then I can hear it, but some how it does Not feel right. I actually have got my hearing tested too, they said it hasn't been any worse than what it was 2 years ago. If you guys can give me any suggestion to get all the audio levels right, I'll be forever grateful.
     
    Last edited: Jan 6, 2013
  2. jumpy

    jumpy Member

    Joined:
    Oct 26, 2002
    Messages:
    2,522
    Location:
    Melbourne
    What you're looking for is 'Dynamic Range Compression', see if you can find any setting in XBMC or on your receiver. edit: called volume amplification in xbmc.
     
    Last edited: Jan 7, 2013
  3. OP
    OP
    bejay

    bejay Member

    Joined:
    Oct 13, 2009
    Messages:
    260
    Location:
    Brisbane, QLD
    Couldn't find volume amplification in system menu of Xbmc. The only place I did find it was in the on screen audio option during movie playback, but it remains disabled for all 5.1 sound formats.
     
  4. Rezin

    Rezin Member

    Joined:
    Oct 27, 2002
    Messages:
    9,485
    This kind of thing has been happening since DVD days (probably even earlier, but I didn't notice). Turn up the volume to hear what they're saying, then FUCKING BOOM the sound effects kick in and nearly shatter your windows. I've tried adjusting the centre speaker volume (which is supposedly the one for voices), but hasn't helped enough.

    Edit: I've tried adjusting levels in alsamixer too, but nothing helped. Probably because it's connected to the telly through HDMI.
    Edit 2: jumpy, doesn't that setting just affect overall volume?
     
    Last edited: Jan 7, 2013
  5. Pugs

    Pugs Member

    Joined:
    Jan 20, 2008
    Messages:
    9,598
    Location:
    Redwood Park, SA
    happens to me too, bloody annoyinhg as.... will have a look to see if the above mentioned tip works
     
  6. Jaysimar

    Jaysimar Member

    Joined:
    Dec 12, 2005
    Messages:
    298
    Location:
    Brisbane
    i had the same issue as rezin, fixed it by going into the speaker calibration on the amp and turning up the dB for the centre speaker (about +6dB for me) and reducing it on the front left and right speaker (-2dB).

    now the conversations are much more level with the music
     
  7. mtma

    mtma Member

    Joined:
    Aug 12, 2009
    Messages:
    6,178
    Are you streaming the DTS/AC3 audio to the receiver (which then does the decoding)

    If you are, then you will need to tweak the DRC settings in the receiver itself.

    Not sure about your exact model, but it may be in the guise of night mode or noisy environment etc. It should have three levels relating to the amount of compression applied.
     
  8. OP
    OP
    bejay

    bejay Member

    Joined:
    Oct 13, 2009
    Messages:
    260
    Location:
    Brisbane, QLD
    Tested late night mode on my onkyo. Low level made bugger all difference and high made a big difference, which was good. But jay thanks for the tip, never thought of reducing the front two.
     
  9. Mau1wurf1977

    Mau1wurf1977 (Banned or Deleted)

    Joined:
    Jul 19, 2006
    Messages:
    13,706
    Location:
    Country WA
    Hehe it's a common problem

    Especially HD material has a huge Dynamic range. This means the difference between something quiet (a whisper) and something loud (an explosion) is massive.

    This is fine in the cinema with matching equipment, but at home it's a bit of a pain. I use a Media PC and tried many solutions like VLC and various media front-ends with noise compression, but I found non of them worked as well as I liked.

    However I now found something that just works and does the job. It's a feaure of the Recon 3D and Z series Sound Blaster cards.

    I recently reviewed the Sound Blaster Z and I demonstrate the feature here:



    Jump to 9:22.

    I use the analog 5.1 outputs to drive Logitech Z906 speakers and it works really well. It has a slider, so you can adjust how much compression you like. So at late night just select max. volume and everything will be audible without having to play volume DJ.

    So this might be a solution to your problem as well.
     
  10. OP
    OP
    bejay

    bejay Member

    Joined:
    Oct 13, 2009
    Messages:
    260
    Location:
    Brisbane, QLD
    That's awesome. Wonder if they have a sound card with hdmi output so that I can bitstream hd audio and do the rest of the stuff that this sound card can
     
  11. Mau1wurf1977

    Mau1wurf1977 (Banned or Deleted)

    Joined:
    Jul 19, 2006
    Messages:
    13,706
    Location:
    Country WA
    It does have optical out and an encoder, but not sure if all the features will work as they do through analogue.
     

Share This Page

Advertisement: